fatal error when updating to drupal 7.12

tran.thnga's picture

I am getting "Fatal error: Call to undefined function drupal_json_encode_helper() in /mnt/www/html/xxxxdev/docroot/includes/common.inc on line 4880" when I upgrade to drupal 7.12. If I go back to 7.11 (which has the security fix) I am fine. Any ideas or suggestions would be appreciated. Thanks

Comments

Please help me solve this

tran.thnga's picture

Please help me solve this problem.....

samcis's picture

Need more details. What Drupal version, what modules, what custom fields, etc?

Well I too have been getting these errors. It show two error messages after updating to 7.12:

Notice: unserialize() [function.unserialize]: Error at offset 2 of 8 bytes in variable_initialize() (line 943 of /home/USER/SITE.coop/includes/bootstrap.inc).

Notice: unserialize() [function.unserialize]: Error at offset 2 of 8 bytes in variable_initialize() (line 943 of /home/USER/SITE.coop/includes/bootstrap.inc).

Have you been getting the same error all the time. Well these errors shown while updating to 7.12 are not serious! You Should just try ignore them and see if it works.