manual install of 7.26 Security update

Coy Lay's picture

I just installed the Open Aid distro, and attempted to load the 7.26 security update. I competed the initial install but did not activate any modules, I put the site in maintenance mode, deleted everything but the sites folder and copied in the 7.26 files sans the site folder. The site came up but it wasn't OpenAid any more. Does anyone know what other files I need to save before I copy in the 7.26 files and folders?

Comments

The profiles folder contain

joelwallis's picture

The profiles folder contain code for the installation profiles. I'm almost sure OpenAid code are stored there.

Joel, That's exactly right.

cedewey's picture

Joel,
That's exactly right. Thanks for chiming in on this.

Coy,

Were you able to perform the security updates successfully? Let me know if not and I'd be happy to assist.

Clayton

update to 7.26

Coy Lay's picture

Clayton, I am not yet able to update Openaid to 7.26.

I copied the existing ./sites and ./profiles folders to a safe place and copied the 7.26 files into the site home directory. I changed the permissions on the new ./sites and ./profiles folders to be writable and copied the previous ./sites and ./profiles folders over the 7.26 ones.

I took the site out of maintenance mode and ran a status report. It came back as updated to 7.26 but in need of a database update. The link to the update database script brought me to a "Unable to find Profile" screen.

I clicked back in the browser (firefox) and tried to rerun the report. I was brought to the page "Select an installation profile" "OpenAid Site" "Install all the modules and features for an OpenAid base site." This is I believe the Install.php.

Now any action will bring up the "Select an installation profile" page. I haven't proceeded past that page yet. Do I need to make a change to the index.php file?

Hi Coy, Sorry to hear you're

cedewey's picture

Hi Coy,

Sorry to hear you're still having issues updating.

The steps you took should work fine. I tried recreating them myself and was able to update Drupal core successfully following your approach. I did not get the database update prompt, which isn't surprising since I didn't have any real substantial content to begin with.

I've never seen the "Unable to find profile" screen. Is that the message you received verbatim? Searching for that fails to bring up any issues from others.

I suggest making a backup of your database and then walking through the installation steps that are displaying. If you aren't taken to the "Your site exists" page, grab a screenshot and let me know what happens. Hopefully we can troubleshoot further from that point.

Success!!? I think.

Coy Lay's picture

Cedway, thanks for your help.

I was successfully able to go through the process on my shared host at hostgator with no issues.

Then I went through things again locally (MacBook OSX 10.9.2) and the status report now shows 7.26 installed. (Success!!?). If I were to guess at why I was having the problem before I'd guess file permissions need to be read-write for everybody on the sites and profiles folders, files, and sub-folders. At the very least the index.php file could not find the profiles folder and/or contents.

However --
I did "chmod -R 777 saveworldart"
I did update manager which identified 14 modules to update. I entered the ftp username and password and got errors as edited below:

====partial quote below=====================
Error message
Update failed! See the log below for more information. Your site is still in maintenance mode.
entity
Error installing / updating
File Transfer failed, reason: Unable to remove to directory /Users/SolarCoy/Sites/saveworldart/profiles/openaid/modules/contrib/entity
====partial quote above=====================

with the same information for: leaflet, ctools, webform, context, date, extlink, features, field_group, geofield, libraries, link, transliteration, views_load_more, and views_slideshow.

and, seemingly inconsistent, at the bottom of the page:

++++partial quote below+++++++++++++++++++++++
Your modules have been downloaded and updated.
Run database updates
++++partial quote above+++++++++++++++++++++++

Could it be that the errors above are false negatives? The folders were already in place and did have contents.

I went ahead and ran the db updates and everything seemed to work (success!!?) with the following exception that I don't know what to make of:

Strict warning: Declaration of simple_ol_popup::options_form() should be compatible with openlayers_behavior::options_form($defaults = Array) in ctools_plugin_load_includes() (line 475 of /Users/SolarCoy/Sites/saveworldart/profiles/openaid/modules/contrib/ctools/includes/plugins.inc).

If you know what this is and what I need to do if anything, let me know.

I think I'm OK now but I just thought I should pass along the experience, the possible false negative, and whatever the "Strict warning" is.

I have some continuing configuration issues but I'll open up another discussion or two about them.

Thanks again for your help.

grumble

Coy Lay's picture

I'm getting a "problems detected..." warning on the configuration menu page and the update shows the same modules need updating. The update process shows the same 15 modules and results in the same list of errors. The database update script gave the same error as before. I seem to be functional but it will be tomorrow before I can do some more comprehensive checks.

You can check out the site contents at www.drupal.saveworldart.org. I'll be glad to give you admin access if you'd like to look things over. There really isn't much there right now but it will be filling out over the next few days.

Continuing Issue with module updates

Coy Lay's picture

On my localhost I am still getting notifications I have module updates and the same error messages when I click the update link:

Error message
Update failed! See the log below for more information. Your site is still in maintenance mode.
entity
Error installing / updating
File Transfer failed, reason: Unable to remove to directory /Users/SolarCoy/Sites/saveworldart/profiles/openaid/modules/contrib/entity

with the same information for: leaflet, ctools, webform, context, date, extlink, features, field_group, geofield, libraries, link, transliteration, views_load_more, and views_slidesh

I researched the various hits on module update issues and found several very similar issues but none of the solutions worked for me. I've tried two different FTP solutions and at this point I have tentatively concluded the error messages are misleading.

I don't feel driven to update 15 modules by hand and will sail on for now in my present condition.

Hi Coy, Sorry you're having

cedewey's picture

Hi Coy,

Sorry you're having so many weird issues. If you'd like me to take a look at the site as administrator, let me know in a direct message here on drupal.org

Clayton

OpenAid

Group organizers

Group notifications

This group offers an RSS feed. Or subscribe to these personalized, sitewide feeds:

Hot content this week