Fatal error: require_once() [function.require]....bootstrap.inc on line 3102

jggarley's picture

Please Help Me - My site is down!

I was trying to update my modules and my site crashed. I can't login or access the site. The site is currently offline. any help will highly be appreciated. Below is the full error message

Fatal error: require_once() [function.require]: Failed opening required '/home/ulaalibo/public_html/sites/all/modules/views/plugins/views_plugin_display_attachment.inc' (include_path='.:/usr/lib/php') in /home/ulaalibo/public_html/includes/bootstrap.inc on line 3102

Website url
http://ulaalib.org/user/login

Comments

Can you go back a step by

nexions's picture

Can you go back a step by updating your modules folder with the older versions of the modules that worked?

If that solves your problem, then you can work your way back into following the right procedure to update your modules.

The backup I have are the

jggarley's picture

The backup I have are the ones from the Backup and Migrate module scheduled daily backups. Will that help?

Those (from backup and

snowmountain's picture

Those (from backup and migrate) are database backups. The modules are code.

It seems that if you have the database backups, then you can download the modules to get the code, and have everything you need... UNLESS ... you modified some code.

Anyway, that is what I would try - no guarantees though.... there might be a risk, if the versions of the modules code and the data in the database backup don't match. If the database backup and the module code can be known to match, for a previous version known to work - before the update that caused the problem - then I might try this.

  • identify the previous version of modules used before updating them
  • download those versions, before the update, replacing the module code for those modules you updated on the site with the downloaded module code
  • and restore the database backup

Thank you for your trick

mamourou's picture

Excuse me i need you, When we copy the source of bootstrap.ini, where we save ?
I'm new in this domain and i want to developp my competence

This do happen a lot when

binarycubes's picture

This do happen a lot when installing new modules. Restore a backup if you have one else try the following:

      Run the update.php from http://ulaalib.org/update.php ... may need to make some changes via ftp to the settings.php before you can run if you are not able to login as the administrator. See if you can somehow clear the cache.
      If Step 1 fail, go direct to the system table to turn off the modules that you think is causing the problem by setting the status table to 0 but backup your database before proceeding. You can also truncate all tables with prefix cache_ to clear your cache.

    Unable to perform step since

    jggarley's picture

    Unable to perform step since I'm unable to login. I might try step 2. I have truncated all tables with prefix cache_

    Whatever you do backup your

    binarycubes's picture

    Whatever you do backup your database first ... even if it is not functioning now.

    You should still be able to do the update by changing making the following changes in the settings.php file.

    $update_free_access = TRUE;

    But I suspect that your error may be due to the upgrading of the views module? Update.php may work but you probably may want to check that the following file actually exist:

    '/home/ulaalibo/public_html/sites/all/modules/views/plugins/views_plugin_display_attachment.inc'

    I usually turn off a few modules in the system table and see if I can get the site back on and then troubleshoot from there ... eg. using the previous version of views etc..

    Using Drush to restore the registry should work ... but if you do not have DRUSH, you can go to the system table and check the filename column to see if they are pointing to the right module. If your modules are in a different directory, you can change them directly.

    Before restore

    joel_osc's picture

    You may just want to look into drush rebuild regisrty prior to restoring. The module path may be different on the filesystem than what is in the db. The drush rebuild registry will fix that. It is an adf-on to drush, just google how to install it.

    I have never use drush

    jggarley's picture

    I have never use drush before. Is there another way to get this done apart from drush?

    Was it really necessary to

    Garrett Albright's picture

    Was it really necessary to cross-post this to so many disparate groups? The forums on drupal.org or Drupal Answers are better places for general tech support questions at any rate.

    Thank you for your advice. I

    jggarley's picture

    Thank you for your advice. I will take note and not repeat it again.

    After trying all methods from

    jggarley's picture

    After trying all methods from above without solution, I decided to contact the hosting company (GreenGeeks.com) to restore my backups which they did and my site is back online now. Thanks all for your helps and suggestions.

    Did you finaly made your

    DarkUD's picture

    Did you finaly made your updates ? if not get in touch with me I may be able to help you. ( FOR FREE !!! ) So you don't run :p

    Thank

    scaballeronavia's picture

    thank my friends

    martha.ayala's picture

    Hi! How Are you? I need your help. Today I install a module and while I was activate it my site die.
    This is the error, I hope you can help me please!!
    Fatal error: require_once(): Failed opening required '/var/www/vhosts/piensayactua.mx/httpdocs/legisladoresna/sites/all/modules/scald/includes/ScaldAtomController.inc' (include_path='.:') in /var/www/vhosts/piensayactua.mx/httpdocs/legisladoresna/includes/bootstrap.inc on line 3119

    Solved

    martha.ayala's picture

    Hi!, well I solved this error. Thank you !! ^^

    hello i need you plese

    mamourou's picture

    Excuse me i need you, how we do to have a bootstrap.ini source and When we copy the source of bootstrap.ini, where we save him ?
    I'm new in this domain pleese

    post your solution

    mhamed's picture

    Hi all

    can any one please post his solution to make anyone aware of that
    a help for everyone

    thanks

    mhamed

    Try this from the command

    arnoldbird's picture

    Try this from the command line:

    drush rr

    ...or...

    sudo drush rr

    Nice!

    kubica's picture

    Thank you very much! drush rr fix my problem.

    Africa

    Group organizers

    Group categories

    Opportunities

    Group notifications

    This group offers an RSS feed. Or subscribe to these personalized, sitewide feeds:

    Hot content this week