Nginx just stopped

ddols's picture


I just received an email from a client that their site is down. I see that all sites are down, as I believe Nginx is no longer running. When I try to restart it I get the message:

nginx: [emerg] unknown directive "PATH=/usr/local/sbin:/usr/local/bin:/opt/local/bin:/usr/sbin:/usr/bin:/sbin:/bin" in /data/disk/o1/config/server_master/nginx/vhost.d/

Looking in the to error logs, this message is repeated over and over every 10 seconds for days. it appears to have started 7 days ago on the 13th. I have changed nothing lately, I've done no updates, etc. I am not sure when the server stopped.

How do I begin to trouble shoot this? Anyone else if any experience with an issue like this?


Just delete file

omega8cc's picture

Just delete file you have downloaded into Nginx config tree.

Wow that was easy, wish I would have thought of it!

ddols's picture

That did it. I was wondering why that was there, didn't make any sense. It never occured to me I put it there, but I must have. I have no idea how I got it there though :/

Thank you!

In my hours of mucking about trying to fix it, I gave up and started installing a new setup on a new server. Since the old server is over 2 years old and an older version of Debain do you think I should continue with the setup and finish switching everything over? Is there good reason to switch from 6.0 to 7.4? It might at least clean up some file space.


Group organizers

Group notifications

This group offers an RSS feed. Or subscribe to these personalized, sitewide feeds: