No se ven los iframes en una vista

AlvaroDev's picture

Hola, tengo un vista que llama varios campos de un tipo de contenido, los campos están ocultos del display y luego son llamados por un campo global de texto, se están usando patrones de reemplazo para mostrar los campos en un orden y de una manera en especifico para que se visualicen como se definió en el diseño, el problema es que algunos de los campos llamados tienen iframes para mostrar videos de youtube.

El código que puse en el campo de texto es el siguiente

<div class="cursos-continuada">
<section>
        <h2>{{ title }} </h2>
 

      <div class="carrera">
          <div class="carrera-visual">{{ field_cursos_imagen }}
          <ul>
             <li><a href="/aspirantes/inscripcion-en-linea" target="blank"><img alt="" src="/themes/custom/fucs/images/preuniversitario/seccion_1.png" /> </a>

                <p><a href="/aspirantes/inscripcion-en-linea" target="_blank">Inscripción en línea</a></p>
             <a href="/aspirantes/inscripcion-en-linea"> </a></li>
              <li><a href="/continuada/formulario-contacto"><img alt="" src="/themes/custom/fucs/images/preuniversitario/seccion_5.png" /> </a>
                <p><a href="/continuada/formulario-contacto">Solicitar información</a></p>
               <a href="/continuada/formulario-contacto"> </a></li>
               <li><a href="/aspirantes/financiacion"><img alt="" src="/themes/custom/fucs/images/preuniversitario/seccion_4.png" /> </a>
               <p><a href="/aspirantes/financiacion">Financiación</a></p>
               <a href="/aspirantes/financiacion"> </a></li>
          </ul>
            </div>

          <div class="curso-carrera-info">
               <div class="panel-group" id="accordion">
             <div class="panel panel-default">
              <div class="panel-heading">
                <h4 class="panel-title"><a data-parent="#accordion" data-toggle="collapse" >{{ field_titulo_a }}<span class="icon-down-dir"></span></a></h4>
               </div>

              <div class="panel-collapse collapse in" id="collapse1">
              <div class="panel-body">{{ field_cuerpos_acordion_1 }}
                          </div>
              </div>
           </div>

          <div class="panel panel-default">
          <div class="panel-heading">
            <h4 class="panel-title"><a data-parent="#accordion" data-toggle="collapse" >{{ field_titulo
}} <span class="icon-down-dir"></span></a></h4>
           </div>

          <div class="panel-collapse collapse" id="collapse2">
         <div class="panel-body">{{ field_cuer_acor_2 }} </div>
           </div>
           </div>

          <div class="panel panel-default">
          <div class="panel-heading">
            <h4 class="panel-title"><a data-parent="#accordion" data-toggle="collapse" >{{ field_titulos_acordion_3 }} <span class="icon-down-dir"></span></a></h4>
            </div>

          <div class="panel-collapse collapse" id="collapse3">
         <div class="panel-body">{{ field_cur }}</div>
            </div>
           </div>
<div class="panel panel-default">
      <div class="panel-heading">
        <h4 class="panel-title">
          <a data-toggle="collapse" data-parent="#accordion" >Competencias y temas<span class="icon-down-dir"></span></a>
        </h4>
      </div>
      <div id="collapse4" class="panel-collapse collapse">
        <div class="panel-body">{{ field_cuer_acor_4 }}</div>
      </div>
    </div>
         </div>
           </div>
       </div>
   </section>
</div>

El campo {{ field_cuer_acor_2 }} tiene el iframe, y en la salida de la vista solo muestra esto

<div class="panel-collapse collapse" id="collapse2" style="display: block;">
            <div class="panel-body"><p class="text-align-center incrustado"></p>
</div>
           </div>

Remueve el iframe, pero esto solo sucede en la vista, porque en el node que tiene ese iframe si se muestra.

Alguna solución a este problema???

El sitio en cuestion es http://fucsalud.edu.co/diplomados

En el en tab "video" de "Diplomado en Embriología Clínica y Reproductiva "ELKIN LUCENA""

Comments

Pareciera ser por el formato

vramiguez's picture

Pareciera ser por el formato en que estás imprimiendo cada uno de los contenidos ocultos. Revisa que este renderizando con full HTML y que no esté con el resumen o cualquier otro tipo que pueda evitar que la etiqueta se muestre correctamente.

Hola, no es eso... ya

AlvaroDev's picture

Hola, no es eso... ya verifique los formatos de texto y no se debe a eso, incluso cree uno nuevo para verificar si se trataba de los formatos, aun así no funciona.