Drupal.org modules feature request > module php compatibility

wouters_f's picture

Yesterday I was visiting a company with performance issues. I bumped into some corporate trouble.

As I only recently joined the company, decisions were made before my time. We are making a drupal 6 site. There are many reasons for this.

It was planned like that a long time ago
We need modules that aren’t/weren’t ported yet
The client agreed to that.

There is no way of moving to drupal 7 (yet).

According to the drupal requirements page http://drupal.org/requirements#php

Note that some contributed modules may not be compatible with PHP 5.3, …

Because we did not intend to fix all 5.3 uncompliant modules we decided to stick to php 5.2.(imagecache was not 5.3 compliant at that time).

It seems now PHP 5.2 is not supported by Red hat corporate support contracts. This feels as an very unconfortable posisition knowing that the php crashes from time to time. PHP.net community does not support php 5.2 neither. That’s probably why Red Hat does not want to support it either.

So it seems they are now forced to move to php 5.3 and we are forced to retest the entrire cms. This is gonna cost me and the client.

Is it possible to please have a php version compatibility indication on the module page? (Or did I miss this?)

I might have calculated the porting of some modules from 5.2 to 5.3. into the budget. Actually, i would have loved to do that, that’s good fun. Now we are just both unhappy.

For the bigger companies where compatibility (and support) is of importance, this will really make a difference. It also could have spared me a hole lot of head-aches.

What do you guys think of this?


I support this request

stompersly's picture

I think it would be great to add a PHP version compatibility indication on the module page. This would not be very hard to do.
How to display the min and max PHP versions supported
If a module supports PHP 4.x up to PHP 5.2 for example there are three choices:
1. Use a drop down list that shows possible combinations (4, 4-5.1, 4-5.2, 4-5.3, 5.1, 5.1-5.2, 5.1-5.3, 5.2, 5.2-5.3)
2. Use a free form text field and let the editor type in the range of PHP version
3. Have one drop down field for the minimum PHP version and another field for the max PHP version supported.

I would be happy with any of the above. The next best thing would be to show just compatibility with PHP 5.3, for example a drop down with (unknown, none, partial, full) where partial means if you disable warnings everything else works fine.