nginx: The page you are looking for is temporarily unavailable

moallemi's picture

I am using nginx, with php-fm. I am using webform module. when I try to add components to a webform nginx redirects to this page:

The page you are looking for is temporarily unavailable.
Please try again later.

nginx error log:

recv() failed (104: Connection reset by peer) while reading response header from upstream request: "POST /node/78/webform/components/new/textarea?name=%D8%AA%D9%88%D8%B6%DB%8C%D8%AD&mandatory=1&pid=0&weight=0 HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "XXXXX", referrer: "XXXXX/node/78/webform/components/new/textarea?name=%D8%AA%D9%88%D8%B6%DB%8C%D8%AD&mandatory=1&pid=0&weight=0"

Is this happens because of too long request? how can I solve it?

Comments

Check this

perusio's picture

fastcgi_read_timeout .

If your site takes more than 60s (the default) to answer the request, you should fix it. It's way too slow.

Set the log level of php-fpm to debug to further investigate the issue.

Try also to tweak request_terminate_timeout in php-fpm config.

I changed the

moallemi's picture

I changed the request_terminate_timeout and fastcgi_read_timeout but the problem did not solved.

don't you think this is because of too many parameters or the length of the url?

you know enable or disabling a module will take too much long time than saving a webform, but i have not any problem with modules page.

Update: this is php-fm error.log

[19-Mar-2012 21:53:07] WARNING: [pool www] child 2807 exited on signal 11 (SIGSEGV - core dumped) after 2271.853423 seconds from start
[19-Mar-2012 21:53:07] NOTICE: [pool www] child 3343 started

You have

perusio's picture

a problem with your PHP. The SIGSEV means that PHP is crashing.

Try to disable APC and see if that changes things.

Currently I have not

moallemi's picture

Currently I have not installed APC.

The http header response is : 502 Bad Gateway, maybe it can help!

The 502 means

perusio's picture

that your php-fpm setup is faulty. Nginx cannot get an upstream to forward the requests to.

If the problem is just with webform, try to disable and see if the error doesn't occur. If so then hunt the bug in webform. See what triggers the SIGSEV.

currently I have not

moallemi's picture

currently I have not installed APC

Nginx

Group organizers

Group notifications

This group offers an RSS feed. Or subscribe to these personalized, sitewide feeds:

Hot content this week