https ile drupalı kullanmak (kullanamamak)

Simuzer's picture

Merhabalar,

http'den https'e geçtim. Buna göre cpanel'den hazır olarak kurulumunu yaptım.

İnternetten araştırdım,

kimi setttings.php dosyasına tek satırlık bir kod ekleyerek https için aktif yapmayı göstermiş, kimi de .htaccess dosyasına bir kaç satır kod ekleyerek url'leri yeniden yapılandırmış.

Tüm bunları denememe rağmen herhangi bir sonuç netice alamadım. Her seferinde cache'yi temizlememe rağmen.

Drupal admin ayarlar kısmından da http/https vs ile ilgili bir ayar bulamadım.

https olarak site açılıyor herhangi bir kodsal olarak bir hata vermiyor. Ancak resimler ve yazılar yüklenmesine rağmen, css ve js.ler yüklenmediğinden site omurgası bozuk çıkıyor.

Ne yapmamı önerirsiniz.
Teşekkürler.

Comments

admin/config/development/perf

Simuzer's picture

admin/config/development/performance sayfasında

"Bandwidth optimization" başlığı altında;

"Aggregate CSS files" ve "Aggregate JavaScript files" işaretlerini kaldırınca sayfa normal, olması gerektiği gibi açıyor. Ancak bunları tekrar işaretleyince site bozuluyor.

merhaba

Umit's picture

Merhaba

settings.php ve .htaccess dosyalarına yazdıgınız yönlendirme kodlarını paylaşırmısınız?

htaccess dosyasına bu kodu

kopollo's picture

htaccess dosyasına bu kodu ekleyerek httpsye yönlendirebilirsiniz.

RewriteCond %{HTTP_HOST} !^www.
RewriteRule ^(.)$ https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
RewriteCond %{HTTPS} off
RewriteRule ^(.
)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

10.0.0.0.1 IP https://100001.review/ address.