lightningのインストール時エラーはどうすれば?

s-jack's picture

lightningをcomposerでインストールし、acquiadevdesktop2にインポートし、webUIでインストールするとエラーが出るのですが、なぜでしょう?(以前から試してそのうち解消するかなと思っていたのですが、全然変化なしです。)

Drupal\Core\Config\PreExistingConfigException: Configuration objects (core.entity_form_display.media.image.default, core.entity_view_display.media.image.default, media.type.image) provided by lightning_media_image already exist in active configuration in Drupal\Core\Config\PreExistingConfigException::create() (line 65 of /Users/hogehoge/Sites/devdesktop/d8_lightning_test1/docroot/core/lib/Drupal/Core/Config/PreExistingConfigException.php) #0 /Users/hogehoge/Sites/devdesktop/d8_lightning_test1/docroot/core/lib/Drupal/Core/Config/ConfigInstaller.php(492): Drupal\Core\Config\PreExistingConfigException::create(‘lightning_media...’, Array) #1 /Users/hogehoge/Sites/devdesktop/d8_lightning_test1/docroot/core/lib/Drupal/Core/ProxyClass/Config/ConfigInstaller.php(132): Drupal\Core\Config\ConfigInstaller->checkConfigurationToInstall(‘module’, ‘lightning_media...’) #2 /Users/hogehoge/Sites/devdesktop/d8_lightning_test1/docroot/core/lib/Drupal/Core/Extension/ModuleInstaller.php(145): Drupal\Core\ProxyClass\Config\ConfigInstaller->checkConfigurationToInstall(‘module’, ‘lightning_media...’) #3 /Users/hogehoge/Sites/devdesktop/d8_lightning_test1/docroot/core/lib/Drupal/Core/ProxyClass/Extension/ModuleInstaller.php(83): Drupal\Core\Extension\ModuleInstaller->install(Array, false) #4 /Users/hogehoge/Sites/devdesktop/d8_lightning_test1/docroot/core/includes/install.core.inc(1813): Drupal\Core\ProxyClass\Extension\ModuleInstaller->install(Array, false) #5 /Users/hogehoge/Sites/devdesktop/d8_lightning_test1/docroot/core/includes/batch.inc(294): _install_module_batch(‘lightning_media...’, ‘Media Image’, Array) #6 /Users/hogehoge/Sites/devdesktop/d8_lightning_test1/docroot/core/includes/batch.inc(137): _batch_process() #7 /Users/hogehoge/Sites/devdesktop/d8_lightning_test1/docroot/core/includes/batch.inc(93): _batch_do() #8 /Users/hogehoge/Sites/devdesktop/d8_lightning_test1/docroot/core/includes/install.core.inc(647): _batch_page(Object(Symfony\Component\HttpFoundation\Request)) #9 /Users/hogehoge/Sites/devdesktop/d8_lightning_test1/docroot/core/includes/install.core.inc(555): install_run_task(Array, Array) #10 /Users/hogehoge/Sites/devdesktop/d8_lightning_test1/docroot/core/includes/install.core.inc(117): install_run_tasks(Array) #11 /Users/hogehoge/Sites/devdesktop/d8_lightning_test1/docroot/core/install.php(44): install_drupal(Object(Composer\Autoload\ClassLoader)) #12 {main}.

Comments

なお、

s-jack's picture

Isuueの
lightning latest (8.x-2.25) instalation error.
で、

brew install gpatch; brew upgrade gpatch

により、patchはアップーデーツ済みです。
Warning: gpatch 2.7.5 is already installed
Updating Homebrew...
Error: gpatch 2.7.5 already installed
Tomotsugu Kaneko's picture

DevDesktopを使う時はcomposer使わずにアプリのUIからインストールしてはどうでしょう。その差分をとってみたら具体的な原因がわかるかもしれません。

BLT使ってみては?
https://github.com/acquia/blt/blob/8.x/readme/creating-new-project.md

twitter: @snize