ÅÄÖ i e-post från Drupal

Patrick Danielsson's picture

Jag vet inte riktigt vart problem kan tänkas ligga, men efter att jag uppgraderade sajten till D7, så försvinner alla ÅÄÖ från ämnesraden och avsändarens namn.

En ämnesrad kan tex bli "Kopia p inskickat formulr".

Jag använder mig av Mimemail och PHPmailer, är det någon annan som kan tänkas förstå vart problemet ligger?

Comments

Formmail

bambi_2's picture

Jag vet inte alls varför det blir så, men jag använder Webmail-modulen och det fungerar på de sites jag har gjort.
Jag lägger även till SMTP-modulen.

Ann-Britt

Har du provat att skriva in informationen på nytt?

sl27257's picture

Har du provat att skriva in informationen på nytt under D7 för exempelvis ämnesraden och se vad som händer då? Vilken plattform kör du på?

/Thomas

Jag använder Windows Server

Patrick Danielsson's picture

Ja, jag har provat att göra om formulären och skriva om dom, och det verkar inte spela någon roll. Jag använder Windows Server 2008 R2.

Jag vill också göra ett tillägg, de mail som "inte" skickas via till ex Webform, om man vill återställa ett lösenord, så visas dom precis som dom ska, och dom skickas också via SMTP-modulen.

Har du kollat på koden i mailet

Göran's picture

Om mailen som saknar ÅÄÖ har "charset=UTF-8" eller ISO-nrnr som inställning på teckentabell - eller annan variant?
Isf - finns det någon inställning så du kan sätta UTF8 (gemensam ASCII-tabell för alla system-plattformar)?

// Göran

De mail som saknar åäö verkar

Patrick Danielsson's picture

De mail som saknar åäö verkar inte ha någon charset inställt överhuvudtaget:

h=From:Subject:To:Message-Id:Date:MIME-Version:Content-Type; i=mail@mail.se;
Subject : To : Message-Id : Date : MIME-Version : Content-Type : From :
X-Mailer: Drupal Webform (PHP/5.3.17)

Om man jämför med de andra mailen som skickas om man tex vill återställa till lösenord:

From: =?utf-8?Q?Hemsidans=C2=AE=20Namn?= <mail@mail.se>
Subject: =?utf-8?Q?Ny=20inloggningsinformation=20f=C3=B6r=20Hemsidans=C2=AE=20Namn?=
X-Mailer: PHPMailer 5.1 (phpmailer.sourceforge.net)
Content-Type: text/plain; charset="utf-8"

Utan charset-inställningar ryms inte utökade tecken

Göran's picture

Felet härleds till att charset saknar inställningar för ASCII-tabell, åäö ligger utanför ASCII-tabellens default-tbl och rensas bort.

Felet härleds nog till "Mimermail"...

// Göran

Jag har suttit och kollat

Patrick Danielsson's picture

Jag har suttit och kollat runt lite på forum, som du säger så verkar MimeMail vara boven i dramat.

Kolla länken här

// Göran

Denna länk hjälpte för mig,

Patrick Danielsson's picture

Denna länk hjälpte för mig, tack för eran input, hjälpte mig!

https://drupal.org/node/1408226

Sweden

Group events

Add to calendar

Group notifications

This group offers an RSS feed. Or subscribe to these personalized, sitewide feeds: