openscholar

mvrweb's picture

create new content types and interlink them

Hi,

I am new to Drupal and OpenScholar. I am using OpenScholar to build an academic website for our research lab. I created new content types such as People, Projects, Funding. I want them to function in the same way as existing content types such as Publications, News etc i.e., it allows us to create new content of that particular type by using "Add New" link.

1) How can this be done for my custom content types?

Read more
angelb's picture

Teaser Break Button Not Inserting a See More Link

Hi All,

We have a user that is having an issue with the Teaser Break button on their Bio page. When they insert this Teaser Break button, it does not render a "See More" link. Their Bio page is on their front page and this teaser Button link is not rendering there or on the actual Bio page. They would also like to use this function on other pages, but the Teaser Button is not there. If they try to manually insert the code,

Read more
marcelolaia's picture

EntityMalformedException: Missing bundle property on entity of type taxonomy_term. in entity_extract_ids() (line 7663 of /includes/common.inc).

EntityMalformedException: Missing bundle property on entity of type taxonomy_term. in entity_extract_ids() (line 7663 of /includes/common.inc).

Notice: Trying to get property of non-object in taxonomy_form_term() (line 735 of /modules/taxonomy/taxonomy.admin.inc).

The website encountered an unexpected error. Please try again later.

Drupal 7.22
Openscholar 3.6
Downloaded from http://openscholar.harvard.edu/download

marcelolaia's picture

PDOException: SQLSTATE[42000] error in Biblio

After add my publications, I got the error: PDOException: SQLSTATE[42000]: Syntax error or access violation: 1064

Read more
marcelolaia's picture

Change Language break openscholar

If I change Language from English to Portuguese, I got WYSIWYG break! The menu bar desapear and the edit area isnt there. If you want, I could send a screenshot.

How I could translate Openscholar!

marcelolaia's picture

Notice: Undefined index: external in locale_url_outbound_alter() (line 1060 of /home/user/public_html/modules/locale/locale.module).

After enable Locale module in Openscholar 7.22-3.6, I got these messages:

Notice: Undefined index: external in locale_url_outbound_alter() (line 1060 of /home/user/public_html/modules/locale/locale.module).
Notice: Undefined index: external in locale_url_outbound_alter() (line 1060 of /home/user/public_html/modules/locale/locale.module).

What is this? How I could desable it?

They appear for all visitors! Register end Anonymous! It is annoying!

Thank you very much!

marcelolaia's picture

"Create your site" not appear for normal user

After install, "Create your site" link only appear for Administrator!

I already setted "Account settings", "Registration and cancellation" to "Visitors, but administrator approval is required"

See the screenshot here:
https://dl.dropboxusercontent.com/u/34009642/Fig_02.png

lancast's picture

Scholar sites creation problem

I have installed Openscholar 3.6, using the ./scripts/build command. The site installs with no error messages. When I go to the new Home page and click on Create Your Scholar Site, the scholar site seems to create properly, with a link to Go There Now and the appropriate url listed. When I go to the new site, I see the message: "The URL might be incorrect or have changed. Please go back to the homepage".

The sites are listed in the content list, but I can only get the URL might be incorrect message.

Read more
sedroca's picture

Scholar-3.5.0

Hi All,

I notice that the Scholar-3.5.0 distribution is organized quite a bit differently than Scholar-3.4.1.

Are the implications of this change discussed someplace?

I only found one mention of it, on the Harvard site:
http://openscholar.harvard.edu/software/openscholar-drupal-7/7x-35

Here, at the end of the change list, under Dev & Infrastructure, they mention:
"Note: this release introduces the make file. Upgrading from 7.x-3.4 to 7.x-3.5 requires extra system operations."

What are these extra system operations specifically?

Read more
humansky's picture

OpenScholar 2.0RC1 Twitter Feed not updating

Hello all,
One of my users just noticed that their Twitter feed hasn't updated for a little over a week now, right around the same time I upgraded OS to version 2.0RC1. Could it be related to the upgrade or perhaps because Twitter has changed the way their API works and the Twitter Pull module hasn't been upgraded yet? Anyone else run into this issue?

Thank you,
Henry

Subscribe with RSS Syndicate content