Drupal plug-in for Eclipse IDE by XTND.US

Chris Charlton's picture

As some of you may already know, XTND.US provides mostly-free Drupal related software, like Drupal & jQuery extensions for Adobe Dreamweaver, and a Drupal Theme Starter app that runs on Mac/Windows/Linux desktops.

XTND.US announces an unnamed Drupal plug-in for Eclipse. With DrupalCon San Francisco 2010 coming up it would be great to see other Eclipse users together during a community BoF. The pre-release is available by adding the following software site to your Eclipse (PDT required).

Open Eclipse and choose the Help menu, then Install New Software. Click the Add button or link and add this new software site to download the Drupal plugin:

Name: XTND.US
Location: http://xtnd.us/downloads/eclipse

Or install from the Eclipse IDE Marketplace - http://marketplace.eclipse.org/content/drupal-eclipse-pdt/

Only local images are allowed.

Features (updated each release)

Provides support for the following Drupal files types:

  • *.module (pictured above)
  • *.install (pictured below)
  • *.test
  • *.info
  • *.po
  • *.theme
  • *.engine
  • PDT already understands *.php & *.inc files.

Only local images are allowed.

Drush and Eclipse

How to run Drush commands in Eclipse: http://groups.drupal.org/node/42452

*At this time Eclipse PDT is required, which is the latest PHP environment plug-in for Eclipse users; phpEclipse is not supported. Aptana should work fine.

http://marketplace.eclipse.org/content/drupal-eclipse-pdt/

Comments

I'd be interested in being a tester

sndev's picture

I run Eclipse 3.5 with PDT.

Yes Please

ussher's picture

Also eclipse (Build id: 20090920-1017) with PDT

Hi, I would love to test the

Summit's picture

Hi, I would love to test the plugin for you!
Greetings, Martijn

Sounds like Fun

jkrause's picture

Count me in, I'd like to test the plugin

Few simillar things want share...

nikhilkala's picture

Hi,

I haven't used Eclipse for PHP related development, but used for Java related programming.

The similar kind of plug-in is provided SUN Micro-systems for Netbeans IDE almost a year back. Netbeans found easy to install on window and Linux box than Eclipse. Using that you can develop custom module and Customs themes.

check here http://www.nikhilkala.com/netbeans_editor_cross_platform_editor_php_drupal

Thanks,
Nikhil Kala

yes please

mossy2100's picture

I'd like to beta test the plugin as well, thanks!

Please also see the attached file, which I wrote earlier this year - it outlines some ideas for adding Drupal support to Eclipse. Maybe the guys at XTND will want to implement them.

Cheers,
Mossy

I reviewed the DOC file

Chris Charlton's picture

@mossy - Thank you for sharing this doc. Many features mentioned overlap the roadmap of the Eclipse plug-in by XTND.US. Personally, I am not sold on the idea of custom "Drupal project", or Drupal Outline/Views (for files, Libraries, Modules, or Themes) since the built-in functionality in Eclipse and Drupal works fine. I wish to keep this module free and try to bring what the Netbeans plugin provides to Eclipse. It's not that they aren't good ideas, in fact early on this plugin had those Views considered but then it seemed like overkill since Drush or Drupal itself can give the list of modules, themes, and libraries.

Planned are wizards to help build folders/files for new modules and themes, plus tons of Drupal code templates (for hooks, Form API to start with).

I am interested in seeing something flesh out for helping discover Hooks and Theme Functions (in a project) better as I feel this is a hump many developers face and take some time to get over.

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

Hook and theme function discovery

gfdickinson's picture

TOTALLY agree Chris! It would be awesome if we had a tool that would allow you to navigate the tree of available hooks and theming functions available for the project that you are working on and combine this feature with some sort of autocomplete...would be sweet. I find myself tediously searching through source code half the time. Has anyone made any progress in this area.

George Dickinson
Software Engineer/Architect
5501 Patterson Ave
Suite 201
Richmond, VA 23220
804.631.3474

pelagicsoftware.com

dynamic hooks

Chris Charlton's picture

One major issue is some modules produce magic hooks, so there's no clear way to expose what hooks are available. The code hints already provide discovery of any PHP function in your project / libraries. If anyone has suggestions, I'd like to hear them to see if they can be coded into this plugin.

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

dynamic hooks

gfdickinson's picture

Yeah, I can see how this would be a very tricky thing to code. I would imagine we would have to parse all of the code for module_invoke functions and be smart about knowing what the name of the module is for the file that you are editing. That way, when coding a module, you could start typing the following:
function module_name
the plugin would then recognize that this is the name of the module and could be a possible theming function or hook. It will have already parsed all source code and created a lookup table of some sort. This will enable the plugin to start offering suggestions of hooks that can be coded.

This is just my first cut at thinking about this, but it seems like it could be possible. There might be a better way to navigate the list of available hooks...like by module name for example.

George Dickinson
Software Engineer/Architect
5501 Patterson Ave
Suite 201
Richmond, VA 23220
804.631.3474

pelagicsoftware.com

Open Method command in Eclipse

Chris Charlton's picture

One way I am able to find some hooks is using the "Navigate > Open Method" command in Eclipse. This will allow you to do a quick search for a method in a project, so as long as your Drupal core is linked to the project then you can search for "hook_nodeapi", "hook_help", etc. I noticed it works best when you have a .module/.inc/.php file open, and not .info or something plain text.

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

I am just getting into Eclipse

Benno Sebastian's picture

I like to try the plugin for Drupal.

i would love to test it out.

theamoeba's picture

i would love to test it out. i am looking for better ways to develop on drupal.

Installing the Drupal plug-in for Eclipse PDT

Chris Charlton's picture

Eclipse plug-in site URL: http://xtnd.us/eclipse/updates

To install the Drupal plug-in for Eclipse (PDT required) just open Eclipse, choose the Help menu, then Install New Software, Add this new software site and choose the Drupal plugin:

Name: XTND.US
Location: http://xtnd.us/downloads/eclipse

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

Drupal for Eclipse IDE plugin v.0.2.1 update

Chris Charlton's picture

Minor update: added *.engine, *.test file types.

New Eclipse plugin URL: http://xtnd.us/downloads/eclipse

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

I installed the eclipse

Summit's picture

I installed the eclipse plugin for drupal, but I am not seeing it anywhere in preferences.
I am on Imac, using Eclipse.

greetings, Martijn

Eclipse PDT required

Chris Charlton's picture

Check under Preferences > General > Content Types.

Do you have the (PHP) PDT plug-in installed? (PDT required)

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

also not seeing it: The

ussher's picture

also not seeing it:
Only local images are allowed.
Only local images are allowed.

The drupal .po and .info are now associated with the text editor, but there is no drupal section in the 'new' after clicking on the 'new' icon or right clicking on a folder in the 'Navigator' or from 'new' in the file menu.

I tried to restart eclipse with the -clean option to see if that changed anything, but it didn't.

(system is running kubuntu linux 9.10)

During install there was also a warning that was complaining about the module being 'unsigned' but i see that quite often so ignored it.

new file wizards is not out yet

Chris Charlton's picture

The "New File" is not released yet. I was showing an example of what's coming next. Sorry to confuse anyone.

By the looks of your screenshots, it is installed correctly. You will notice the Drupal Module & Theme types listed under the PHP content types.

The notice about the plugin being unsigned will be resolved come the 1.0 release (closer to April).

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

New .info file idea & preference pane(s)

Chris Charlton's picture

Only local images are allowed.

Only local images are allowed.

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

Page not found

betz's picture

I get a page not found when going to http://xtnd.us/downloads/eclipse
Where can i find this nice looking module? ^^

greets,
tom

follow the install directions at the top

Chris Charlton's picture

Eclipse can install plugins easily. Follow the directions at the top.

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

Awesome!

rich.yumul's picture

Thanks for the tips this weekend, Chris! Gonna check this plugin out right now.

Rich Yumul
Sage Tree Solutions
www.sagetree.net

Formatter feature

franskuipers's picture

Nice start of an awesome plugin!

Can you set the Preferences -> PHP -> Code Style -> Formatter to '2 spaces'

This is the standard code style for Drupal, PDT is setting it to '1 Tab'

I'd like the spaces setting to be included too

Chris Charlton's picture

I'm interested in having the spaces-versus-tabs preference set too, but if I am not able to do it in the Eclipse API, then I would consider adding a splash screen with "Next steps" to inform a user they should change their whitespace preferences.

I thought about writing a Code Formatter, there's one for Java in Eclipse already - but its a big task for me right now and I feel it'd be best to work on the other elements to get more of this plug-in released. Of course, like Drupal itself, changes would come in updates. :)

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

2 spaces

Karlheinz's picture

FYI, you can always set spacing on a per-project basis. That way, indenting/formatting will be set to 2 spaces on your Drupal projects, and 4 spaces on your other PHP projects.

What I have NOT been able to set is the actual Tab key: it always defaults to 4 spaces, no matter how you have your preferences set in the project.

Also what would be helpful: Auto-indenting on arrays. I can't get Eclipse to do this at all, and it's a total PITA.

Current state?

doompal's picture

This is wonderful. I was just setting out to write such a module, did a bit of research, and found this? Now without being rude, what does the module currently do? I believe I have PDT installed, at least I have an IDE that acknowledges PHP (never too sure what Eclipse calls its features from one release to the next). You say that new->file is not available yet, is it on CVS, I may as well contribute to testing, since I probably won't be writing.

  I assume you are aware of the templates that exist, hook_ etc? I was wondering if they could be incorporated into a module creation plug-in, allow someone else to look after Drupal API changes.

http://drupalcode.org/viewvc/

neurovation.kiwi's picture

http://drupalcode.org/viewvc/drupal/contributions/sandbox/deekayen/eclip...

currently the benefit of the drupal-plugin is quite limited, or am i missing something?

Thanks for sharing the code templates URL

Chris Charlton's picture

Thank you for sharing the Code Templates URL. I will try to contact the author and ask permission to include theirs, plus mine, into a new release of the Eclipse plugin.

Currently the plug-in for Eclipse helps configure PDT (mostly; minus the spaces-tabs preference), so people do not have to do any of those changes by hand. A lot of cool development is being done, and the next release is expect to include my code templates for Drupal API hooks. The release after that would have the File > New wizards.

This plug-in does not solve the following issues: Learning Drupal, Hunger, Famine, or Obesity. Yes, that was a joke.

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

File->new

doompal's picture

Been playing around with this, this afternoon (zulu time). The one difficulty I have is in accessing templates that have been imported from XML, such as the ones I mentioned before. Should I persevere, or have you got this cracked solved?

no template support yet

Chris Charlton's picture

At this time everyone is on their own when working with templates.

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

XTND site overwhelmed?

dwilde1's picture

Folks, I have two Karmic Ubuntu Linux machines, one 64 and one 32-bit, and I'm trying to add the repository for the XTND Drupal plugins but both my eclipses go away and don't respond after adding the repo in the dialog box. The 64 is the Zend all-in-one and the 32-bitter is the Ubuntu-stock 3.5.1 with the Zend bits added piecemeal on top of my other configs. I'm on a cable modem and I've boosted the -vmargs to 1024M on the 64.

Update -

The 32-bit machine finally accepted the repo after 20 minutes of pushing and shoving. Still waiting on the 64.

32-64 bit Eclipse repo issue

Chris Charlton's picture

I hope this was a fluke. I have personally not had issues installing both the 32 & 64-bit editions of Eclipse including my plug-ins. Please let me know if this issue or any others pop up (again).

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

Hmmm...

Karlheinz's picture

It seems very nice, but what's with the closed-source license?

i have problem in downloading the plugin..

princeabe16's picture

An error occurred while collecting items to be installed
session context was:(profile=epp.package.php, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Artifact not found: org.eclipse.update.feature,Drupal_for_Eclipse_PDT,0.2.0.201001010204.
http://xtnd.us/downloads/eclipse/features/Drupal_for_Eclipse_PDT_0.2.0.2...
Artifact not found: osgi.bundle,us.xtnd.eclipse.pdt.plugin.drupal,0.2.0.201001010204.
http://xtnd.us/downloads/eclipse/plugins/us.xtnd.eclipse.pdt.plugin.drup...

Still having the "ARTIFACT NOT FOUND" error?

Chris Charlton's picture

I checked the site and things seem fine on XTND.US. Is this Eclipse a fresh install? Did you have PDT installed?

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

yes its a fresh

princeabe16's picture

yes its a fresh install.

Eclipse for PHP Developers
http://www.eclipse.org/downloads/download.php?file=/technology/epp/downl...

thanks for the fast respond. God bless

Installed the plugin... now what

craigmc's picture

BTW I'm using the Zend modified version of Eclipse-- Zend Studio v. 7.2
I see the content types defined under Text->PHP, and they're getting recognized. Not sure what other functionality is integrated at this time...

I went ahead and installed the templates from the link that neurovation.kiwi provided, which is also very useful...

Craig

Los Angeles, CA

Nice plugin, alas unsigned

phecht's picture

Hello, it is rare a plugin is signed. Anyway we can get this one signed? I installed it but got the familiar warning that it is unsigned content.

Chris Charlton's picture

I have plans to get the plug-in signed at a much later time. There has been some good developments done on this. In fact, I am personally using the new Eclipse 3.6 "Helios" that ships with the updated PDT 2.2 and so far there are no major API changes. I'm fleshing out more features that built on top of Eclipse/PDT, and are awesome time savers for Drupal developers. The bonus today is the features appear to be both Eclipse 3.5 & 3.6 compatible.

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

Chris Charlton's picture

http://marketplace.eclipse.org/content/drupal-eclipse-pdt/

The early release of the Drupal plugin for Eclipse IDE is now listed on the Eclipse Marketplace.

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

where?

real_ate's picture

Hi Chris, I just tried to get your eclipse plugin through the market place on Eclipse 3.6 for 64 bit Linux and it didn't show up when I was searching for it! I tried "Drupal" and then a whole load of the tags on it in the marketplace but it didn't show up ever!

Drupal isn't being censored is it? ;)

Missing content types

whatdoesitwant's picture

I noticed the following missing content types:
PHP:
*.profile (Drupal profile)
TXT
*.make (Drupal .Info)
*.build (Drupal.info)

I can easily add them by hand but how do you create those titles, e.g. "Drupal profile". That's so pretty. :-)

Available in the dev version of the plug-in

Chris Charlton's picture

*.profile should be in there, if not it's in a dev release I use internally. I'll work on getting an update if it's missing, I'll try the published plug-in on a fresh install on a second machine. Thanks for the support.

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

nice

IT100's picture

nice work guys -

appache 2.2.11
php 5.2.11
mysql 5.0.51

Eclipse Helios for PHP Developers
and Drupal for Eclipse PDT 0.2.1.201001011121

runs very nice.
I'm gonna have to donate.

Chris.

Norton WARNING for xtnd.us : Many threats

chipway's picture

Hi,

Why do i get so many threats on Norton for xtnd.us ?

Was the site hacked ?

Norton Rating

xtnd.us
Summary
•Computer Threats: 1968
•Identity Threats: 0
•Annoyance factors: 0
Total threats on this site: 1968

Thanks

Will look into Norton warnings

Chris Charlton's picture

I'll look into it. I'm updating the site to D7.

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

Drupal 7

Mac_Weber's picture

how to get it to work with D7 new functions? can I somehow use ctags to do it?

D7, cool, cool

Chris Charlton's picture

Yep, D7 stuff is needed. I've been coding in D7 and am dying to update the module. I'll look for time soon. I see a couple comments about opening the code and I'm considering it but honestly if there isn't enough Java coders interested then there's no point if people end up forking it to do something new all the time.

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

Is the code available somewhere?

dkingofpa's picture

I'd like to hack on this and I'm sure others would as well. It would be nice to get the whole Drupal community behind something like this. Is the code available somewhere? Maybe up on GitHub?

Is the code available somewhere?

doompal's picture

I think you'll find that apart from the code not actually working, it has been released under a commercial license. The author might have asked for help in testing it, but he would seem to be more interested in enriching himself than helping the community.

What code doesn't work

Chris Charlton's picture

@doompal: What code doesn't work? Please contact me with details, if available. Secondly, if you look at my profile/site you'll see I do more than my share for open source & webdev communities. You may even like my Drupal Themes training. :)

@all: if you actually code in Java and want to help, contact me. I enjoy working on this and have tons of elements half-baked in a dev build. Finishing it up to release will be awesome.

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

XTND.US

whatdoesitwant's picture

Something weird is going on with the update site. When you add it to your Available Software Sites with the address http://xtnd.us/downloads/eclipse it will not work. But when you add XTND.US as the name it will. I tested with PDT 2.2 on Eclipse Helios (32 & 64). That's awesome, otherwise you would need to set all settings manually (as described at mediacurrent).
Doompal, I get where you're coming from, but the longer I live with Drupal the more important I feel it is to stay constructive.

Nice job

joostvdl's picture

Nice job

I'm using Helios, and when I

MrMaksimize's picture

I'm using Helios, and when I try to download the plugin, the PHP code templates don't get imported for some reason. Is there any way to just get the code templates?

Templates not included yet

Chris Charlton's picture

I have a working version that bundles the templates but there's a lot of work to handle the pref/control/wizards of those templates added, they don't just append into the PHP Templates - trust me, I wish it did! More on this later.

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

syntax highlighting

j_nunes's picture

Where is the syntax highlighting in Eclipse PDT with XTND.US plugin?

Best Regards,
Jorge Nunes

Syntax Highlighting should be automatic

Chris Charlton's picture

You should be seeing syntax highlighting automatically. The plug-in does not conflict with standard PDT/Eclipse. Try checking for any updates as PDT (and Eclipse) had some major updates this year.

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

Aptana ?

tigron's picture

I think I'm missing something as well. I installed this in Aptana 3 and the drupal .po and .info are now associated with the text editor, but there is no drupal PHP content type with Drupal modules and themes. I also don't have the others .module,.install,*.test, *.theme,
*.engine. I know I can do it manually but everyone else seems to have no issues, am I missing something ?

No difference in PDT for Apatana versus Eclipse

Chris Charlton's picture

@tigron - you should not have experienced any differences between those using plain Eclipse versus Apatana (which is built on top of PDT as well). Either way, add the content types manually for now and expect a new plug-in this Winter that will knock your socks off!

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

Using configured eclipse

vishalpurandare's picture

Hi I am new to the drupal, looking for module development.

How to effectively use the configured eclipse for module development..? any tutorial link would do,
and can i get any module development tutorial,
which will provide effective use of Drupal 6 API for module development.

Eclipse on Mac not work for me

mts204's picture

Hi, please help me.
I am new in Eclipse on my Mac, I installed the plugin version 0.2.1.201001011121 . In preferences-content types shows Drupal and under tab PHP all the files types relevant at Drupal Modules.
But when I create a new file not show the option "Drupal". I forced the extension module and this not recognize any hook...

PLease helping me to configure it.

Thanks!!

Another site for the Drupal Eclipse plugin?

debmowry's picture

Does anyone know of another site where you can get the plugin?

I've been trying for a day and a half to get the plugin and neither URL in the node is working; http://xtnd.us/downloads/eclipse or http://marketplace.eclipse.org/content/drupal-eclipse-pdt/ and it is very frustrating.

I went through and did all the settings manually for my laptop and don't want to replicate that on two desktop computers when a simple plugin is supposed to accomplish the same thing. The page at the marketplace says you can drag and drop to your Indigo workspace but that doesn't work either.

Thanks

I too can not seem to get

airspoon's picture

I too can not seem to get access to the repository @ XTND.US through eclipse, nor can I install it through the marketplace. XTND.US seems to be down, throwing a few errors. Is this temporary, or should we expect the site and the plugin to be available again?

XTND.US site relaunched

Chris Charlton's picture

I'm sorry for the downtime. I was relaunching the site this weekend. The site is back up now so feel free to get your plugins!

FWIW, the site went from being an old Drupal 5 install to a fresh, new Drupal 7 site (using an simple custom Omega sub-theme). The site will grow over time; I've thought about adding forums for chatter & requests.

And yes, this is preparation for the new stuff coming from XTND.US - updated plug-ins galore! I have even decided to split the development paths of the Eclipse & Dreamweaver plug-ins. The Eclipse plug-in will be for module development first, and the Dreamweaver extension will focus on Theme building & design features. The Eclipse plug-in would catch up to some degree but not the other way around. (I even have a set of Drush settings/buttons within Eclipse, but more on that later...)

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

XTND.US site relaunched

Hi Chris, I'm trying to

airspoon's picture

Hi Chris,
First, thanks for the eclipse plugin, I just installed it a few hours ago. However, I'm now trying to install the themeStarter AIR application (Ubuntu 11.04 with AIR runtime installed) and I'm getting an error saying that the installer is broken. Is this due to lack of support for Ubuntu? Or, is the installer actually damaged? FWIW, I downloaded the app several times and tried to install it again, yet same error message.

current versions of AIR

Chris Charlton's picture

I will need to verify with the recent versions of Adobe AIR about Ubuntu. But I do know the installer package was not broken, some people did notice their machines tried to unzip the installer which is wrong but not their fault.

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

Check out my blog post for

pwaterz's picture

Check out my blog post for eclipse indigo and drupal plugin http://www.patrickjwaters.com/blog/2011-07-24/how-setup-eclipse-php-pdt-...

xtnd.com Drupal for Eclipse status unknown

bwood's picture

Was just trying to use xtnd.com's Drupal plugin for Eclipse with

Version: Helios Release
Build id: 20100617-1415

on Mac OS 10.7. This plugin has worked well in the past, but this time around I found that it's content types are no longer recognized by Eclipse. E.g. I can't create a PHP file that ends in .module.

It's pretty quick to uninstall this plugin and then do http://drupal.org/node/75242#PDT by hand. Then it works.

will get this fixed

Chris Charlton's picture

I'll get this fixed.

Chris Charlton, Author & Drupal Community Leader, Enterprise Level Consultant

I teach you how to build Drupal Themes http://tinyurl.com/theme-drupal and provide add-on software at http://xtnd.us

Error during install

Joe Murray's picture

Any sense of whether there is something I can do to avoid this error?

An error occurred while installing the items
session context was:(profile=studioProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]Drupal_for_Eclipse_PDT.feature.jar 0.2.1.201001011121, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallFeatureAction).
Error while loading manipulator.
Error while loading manipulator.

Joe Murray

Error during install

joseph.olstad's picture

Hi Joe
What version of Eclipse are you using? Include the version of JVM that you are running (java virtual machine). What version of PDT libraries are you using?

If this is a new fresh install, you might try grabbing eclipse from the PDT website. http://www.eclipse.org/projects/project.php?id=tools.pdt
This distribution of Eclipse is designed for the PDT plugins and should work better for this drupal extension.

Other items:
Have you tried quitting Eclipse and reloading it then trying again?

Or, try switching workspaces, try again.

If you get desperate:
Rename your hidden folders for Eclipse (in Linux they start with . (dot) and are located in your home directory) , Eclipse will create a new hidden folder, this will mean re-loading all plugins however and configuration, not recommended unless you're desperate.

Can't use PDT + Drupal with latest Aptana 3

lefnire's picture

I'm not sure which minor version it was, 3.1 maybe? Added a lock on Drupal content types (*.module, *.inc, *.install, etc) to their own PHP Editor. The editor is incompatible with PDT, meaning no XDebug, and you can't use the Eclipse Drupal integration suite (which are based on PDT). You actually can't break that lock, and it causes errors: so the Drupal + PDT + Aptana combo actually doesn't work anymore. See APSTUD-4668 and APSTUD-3864.

I've had to abandon Aptana for Drupal development & return to Eclipse classic + PDT. I keep Aptana around still for Node & Rails development.

kirankumarkadali's picture

Hi

I am using eclipse-php-helios-SR2-win32 for developing PHP. for developing drupal modules i have installed XTND.US from http://xtnd.us/downloads/eclipse.

I didnt found any option to start drupal module development. Plz help me with clear guidelines.

Thanks in Advance

Any plans to support Eclipse 4.x?

svenryen's picture

I tried installing your plugin in Eclipse Juno. There was a dialog during installation warning me that your plugin was unsigned, though I accepted that and let it continue. I was then asked to restart.

After restart, I see no new features under "File->New Project", "Prefereences"or "Views". Can you help share some documentation for your plugin?

EDIT: I realize from your marketplace entry that you're so far supporting Eclipse 3.8. Would you have any plans of supporting 4.2 or the upcoming 4.3? I don't really know what the benefits are with 4.2 compared to 3.8 though the higher version appealed to me when I picked my Eclipse download ;)

how do i use this?

laurencefass's picture

hi i have just installed this module into eclipse. Observations:

  1. Lack of documentation and nowhere obvious to raise issues (hence I'm submitting comments...). Where do I go with problems/blocks?
  2. I was expecting new project types: Drupal project, Drupal module, Drupal feature(? possible future work). At least a new project type: I get none... Is that correct?
  3. No feature list? I've seen some updates under Windows|Preferences but full list very useful.

Thanks

Drupal IDE

joseph.olstad's picture

I enjoyed the Netbeans experience a lot more.

http://www.hollyit.net/documentation/drupal-development-tool-netbeans

However for real debugging of Drupal you should learn to use the devel module http://drupal.org/project/devel because traditional ide debugging with Drupal is a lot of work because you'll potentially hit every line of code in activated modules as well as core. You're better off targetting your debugging. using either devel or the following two methods.

if you're lucky enough to be on Linux or *nix , you can use strace to debug communications between drupal and apache
strace:
https://github.com/wet-boew/wet-boew-drupal/wiki/Debugging-apache-with-s...

Alternatively for MySQL debugging use tcpdump to debug mysql queries following our docs here:

tcpdump
https://github.com/wet-boew/wet-boew-drupal/wiki/Debugging-queries-with-...

if you have any comments about the last two wiki documents or problems using it, let me know so I can adjust the documentation if necessary.

LA Drupal [Los Angeles Drupal]

Group events

Add to calendar

Group notifications

This group offers an RSS feed. Or subscribe to these personalized, sitewide feeds:

Hot content this week